Kotlin Multiplatform protocol codec system for the buffer library

Artifacts using buffer-codec version 6.30.1 (7)
Sort by:Popular▼

Simple multiplatform kotlin coroutines based socket.
Last Release on Oct 4, 2026
Kotlin Multiplatform Flow extensions for the buffer library
Last Release on Aug 29, 2026
First-class UDP datagram substrate for Kotlin Multiplatform — the buffer-flow datagram trichotomy (addressed, unreliable, pre-framed messages) on real sockets, zero-copy and zero-alloc many-dest
Last Release on Oct 4, 2026
HTTP/3 (RFC 9114) client for Kotlin Multiplatform on top of socket-quic (frame + QPACK codecs, zero-copy)
Last Release on Oct 4, 2026
dcSCTP-style SCTP subset over DTLS (RFC 8831) + DCEP (RFC 8832) - pure Kotlin, sans-io.
Last Release on Aug 16, 2026
STUN/TURN wire codec (RFC 8489/8656) and sans-io transaction machines.
Last Release on Aug 15, 2026
Kotlin Multiplatform Ktor 3 channel bridges, ContentConverter, and WebSocket helpers for the buffer library
Last Release on Aug 29, 2026
  • Prev
  • 1
  • Next