基于Selenium的自动化测试框架Phoenix,采用Java语言编写的。到目前为止,已经覆盖了WebUI自动化测试过程中需要的大部分功能封装。

LicenseApache 2.0
Tagsframeworktestingweb
HomePage https://github.com/LinuxSuRen/phoenix.webui.framework
DateJun 29, 2017
Filespom (8 KB)  jar (305 KB)  View All
RepositoriesCentralSonatypeSpring Lib MSpring Plugins
Ranking#294271 in MvnRepository (See Top Artifacts)
Used By1 artifacts
VulnerabilitiesVulnerabilities from dependencies:
CVE-2023-6378
CVE-2022-41854
CVE-2022-38752
View 17 more ...

Note: There is a new version for this artifact

New Version2.0.0-20170722


Compile Dependencies (26)

Category/License Group / ArtifactVersionUpdates
Logging
EPL 1.0LGPL 2.1
ch.qos.logback » logback-classic2 vulnerabilities 1.1.31.5.0

Apache 2.0
com.surenpi.autotest » autotest.interface.framework 1.0.1-20170422

Apache 2.0
com.surenpi.autotest » autotest.webdriver.downloader 1.0.2-201704221.0.4

Apache 2.0
com.surenpi.autotest » autotest.report 1.0.0-201706181.0.2
Base64
Apache 2.0
commons-codec » commons-codec 1.101.16.1
XML Processing
dom4j » dom4j2 vulnerabilities 1.6.12.1.4
Java Spec
EPL 2.0GPL
javax.annotation » javax.annotation-api 1.22.1.1
Mail Client
CDDLGPL 2.0
javax.mail » mail 1.4.71.6.2
XPath
BSD 2-clause
jaxen » jaxen 1.1.62.0.0
Excel Lib
Apache 2.0
org.apache.poi » poi5 vulnerabilities 3.10.15.2.5

Apache 2.0
org.apache.poi » poi-ooxml 3.10-FINAL5.2.5

Apache 2.0
org.apache.ws.xmlschema » xmlschema-core 2.1.02.3.1
AOP
EPL 2.0
org.aspectj » aspectjrt 1.8.71.9.21.1
AOP
EPL 2.0
org.aspectj » aspectjweaver 1.8.71.9.21.1
JVM Languages
Apache 2.0
org.codehaus.groovy » groovy1 vulnerability 2.4.44.0.18
Lang Runtime
Apache 2.0
org.codehaus.groovy » groovy-jsr223 2.4.44.0.18

EPL 1.0
org.eclipse.jdt » core 3.3.0-v_771
Template Engine
Apache 2.0
org.freemarker » freemarker 2.3.202.3.32
Web Testing
Apache 2.0
org.seleniumhq.selenium » selenium-java 3.3.14.18.1

Apache 2.0
org.seleniumhq.selenium » selenium-support 3.3.14.18.1

Apache 2.0
org.seleniumhq.selenium » selenium-remote-driver 3.3.14.18.1
Dep Injection
Apache 2.0
org.springframework » spring-context1 vulnerability 4.3.7.RELEASE6.1.4
Config
Apache 2.0
org.springframework » spring-context-support 4.3.7.RELEASE6.1.4
AOP
Apache 2.0
org.springframework » spring-aop 4.3.7.RELEASE6.1.4
YAML
Apache 2.0
org.yaml » snakeyaml8 vulnerabilities 1.52.2
XML Processing
ApacheW3C
xml-apis » xml-apis 1.4.012.0.2

Test Dependencies (3)

Licenses

LicenseURL
Apache2.0 http://surenpi.com

Developers

NameEmailDev IdRolesOrganization
surensurenowner