Indexed Artifacts (25.5M)

Popular Categories

Jenkins Warnings Next Generation plugin collects compiler warnings or issues reported by static analysis tools and visualizes the results. It has built-in support for numerous static analysis tools (including several compilers), see the list of supported report formats.

LicenseMIT
HomePage https://github.com/jenkinsci/warnings-ng-plugin
Date(Mar 08, 2020)
Fileshpi   View All
RepositoriesJenkins Releases
Used By6 artifacts
VulnerabilitiesDirect vulnerabilities:
CVE-2022-23107

Vulnerabilities from dependencies:
CVE-2022-20612
CVE-2021-29425
CVE-2021-27568
View 37 more ...

Note: There is a new version for this artifact

New Version9.10.3


Note: this artifact is located at Jenkins Releases repository (https://repo.jenkins-ci.org/releases/)

Compile Dependencies (32)

Category/License Group / ArtifactVersionUpdates
JSON Lib
Apache 2.0
com.fasterxml.jackson.core » jackson-databind35 vulnerabilities 2.9.10.12.13.1
Defect Detection
LGPL 2.1
com.github.spotbugs » spotbugs-annotations 4.0.04.5.3
Defect Detection
Apache 2.0
com.google.errorprone » error_prone_annotations 2.3.42.11.0

Apache 2.0
com.j2html » j2html 1.4.01.5.0
I/O
Apache 2.0
commons-io » commons-io1 vulnerability 2.62.11.0

MIT
io.jenkins.plugins » plugin-util-api 1.0.12.12.0

MIT
io.jenkins.plugins » analysis-model-api 8.0.010.9.1

MIT
io.jenkins.plugins » font-awesome-api 5.12.0-75.15.4-5

MIT
io.jenkins.plugins » bootstrap4-api 4.4.1-104.6.0-3

MIT
io.jenkins.plugins » jquery3-api 3.4.1-103.6.0-2

MIT
io.jenkins.plugins » echarts-api 4.6.0-75.2.2-2

MIT
io.jenkins.plugins » data-tables-api 1.10.20-131.11.3-6

MIT
io.jenkins.plugins » forensics-api 0.7.01.7.0
JSON Lib
Apache 2.0
net.minidev » json-smart1 vulnerability 2.32.4.7

BSD
net.sourceforge.pmd » pmd-core 6.21.06.41.0

BSD
net.sourceforge.pmd » pmd-java 6.21.06.41.0
Core Utils
Apache 2.0
org.apache.commons » commons-lang3 3.93.12.0
Config
Apache 2.0
org.apache.commons » commons-digester3 3.2
String Utils
Apache 2.0
org.apache.commons » commons-text 1.81.9
Collections
EDL 1.0EPL 1.0
org.eclipse.collections » eclipse-collections-api 9.2.011.0.0
Collections
EDL 1.0EPL 1.0
org.eclipse.collections » eclipse-collections 9.2.011.0.0

MIT
org.jenkins-ci.plugins » structs 1.20313.v41142fb_07c92

MIT
org.jenkins-ci.plugins » antisamy-markup-formatter 1.5136.v94fb_413c7721

MIT
org.jenkins-ci.plugins » credentials1 vulnerability 2.3.01075.vb_8181435509f

MIT
org.jenkins-ci.plugins » apache-httpcomponents-client-4-api 4.5.10-2.04.5.13-1.0

MIT
org.jenkins-ci.plugins » matrix-project (optional) 1.141.20

MIT
org.jenkins-ci.plugins » token-macro (optional) 2.10272.v147d367e0ae8

MIT
org.jenkins-ci.plugins » dashboard-view (optional) 1 vulnerability 2.9.42.18

MIT
org.jenkins-ci.plugins.workflow » workflow-api 2.371136.v7f5f1759dc16

MIT
org.jenkins-ci.plugins.workflow » workflow-cps 2.762655.vf067f7de3352

MIT
org.jenkins-ci.plugins.workflow » workflow-step-api 2.20625.v2e7cf5fc4211

MIT
org.jenkins-ci.plugins.workflow » workflow-job 2.361171.vf16124d81e34

Provided Dependencies (2)

Licenses

LicenseURL
MIT license

Developers

NameEmailDev IdRolesOrganization
Ullrich Hafnerullrich.hafner<at>gmail.comuhafner