ODE Interface Layers Common

LicenseApache
Tagsbpelapache
DateApr 26, 2017
Filespom (4 KB)  jar (57 KB)  View All
RepositoriesCentral
Ranking#36328 in MvnRepository (See Top Artifacts)
Used By11 artifacts
VulnerabilitiesVulnerabilities from dependencies:
CVE-2022-46337
CVE-2022-45868
CVE-2022-23437
View 17 more ...

Note: There is a new version for this artifact

New Version1.3.8


Compile Dependencies (24)

Category/License Group / ArtifactVersionUpdates
Embedded SQL DB
EPL 1.0MPL 2.0
com.h2database » h23 vulnerabilities 1.3.1762.3.230
Reflection
Apache 2.0
commons-beanutils » commons-beanutils2 vulnerabilities 1.8.21.9.4
Core Utils
Apache 2.0
commons-lang » commons-lang 2.43.15.0
Collections
Apache
commons-primitives » commons-primitives 1.020041207.202534
JDBC Driver
Apache 2.0
org.apache.derby » derby4 vulnerabilities 10.5.3.0_110.17.1.0
Transactions
Apache 2.0
org.apache.geronimo.components » geronimo-transaction 2.0.14.0.0

Apache 2.0
org.apache.geronimo.components » geronimo-connector 2.0.14.0.0

Apache 2.0
org.apache.geronimo.specs » geronimo-j2ee-connector_1.5_spec 1.02.0.0
Transactions
EPL 2.0GPL
org.apache.geronimo.specs » geronimo-jta_1.1_spec 1.12.0.1
Logging
Apache 2.0
org.apache.logging.log4j » log4j-api 2.32.23.1
Logging
Apache 2.0
org.apache.logging.log4j » log4j-core6 vulnerabilities 2.32.23.1
Logging Bridge
Apache 2.0
org.apache.logging.log4j » log4j-slf4j-impl 2.32.23.1
Logging
Apache 2.0
org.apache.logging.log4j » log4j-web 2.32.23.1

Apache 2.0
org.apache.ode » ode-utils 1.3.71.3.8

Apache 2.0
org.apache.ode » ode-bpel-dao 1.3.71.3.8

Apache 2.0
org.apache.ode » ode-bpel-api 1.3.71.3.8

Apache 2.0
org.apache.ws.commons.axiom » axiom-api 1.2.131.4.0

Apache 2.0
org.apache.ws.commons.axiom » axiom-impl 1.2.131.4.0

Apache 2.0
org.apache.ws.commons.axiom » axiom-dom 1.2.131.4.0
XML Processing
Apache 2.0
org.apache.xmlbeans » xmlbeans1 vulnerability 2.6.05.2.1
Logging
MIT
org.slf4j » slf4j-api 1.7.122.0.13
Logging Bridge
Apache 2.0
org.slf4j » jcl-over-slf4j 1.7.122.0.13
XML Processing
CDDL 1.0GPL
stax » stax-api 1.0.11.0-2

Apache 2.0
tranql » tranql-connector 1.11.8

Test Dependencies (2)

Category/License Group / ArtifactVersionUpdates
XML Processing
Apache 2.0
xerces » xercesImpl4 vulnerabilities 2.11.02.12.2
XML Processing
ApacheW3C
xml-apis » xml-apis 1.4.012.0.2