Indexed Artifacts (29.9M)

Popular Categories

Apache Solr Velocity

LicenseApache 2.0
Tagsapachesolrsearch
DateJun 24, 2014
Filespom (11 KB)  jar (20 KB)  View All
RepositoriesCentralApache ReleasesApache StagingIBiblio
Ranking#54924 in MvnRepository (See Top Artifacts)
Used By6 artifacts
VulnerabilitiesVulnerabilities from dependencies:
CVE-2022-26612
CVE-2022-25168
CVE-2022-23305
View 46 more ...

Note: There is a new version for this artifact

New Version8.11.2


Compile Dependencies (65)

Category/License Group / ArtifactVersionUpdates
Collections
Apache 2.0
com.carrotsearch » hppc 0.5.20.9.1
Core Utils
Apache 2.0
com.google.guava » guava2 vulnerabilities 14.0.131.1-jre
Data Format
BSD 3-clause
com.google.protobuf » protobuf-java1 vulnerability 2.5.03.21.7
Collections
Apache 2.0
com.googlecode.concurrentlinkedhashmap » concurrentlinkedhashmap-lru 1.21.4.2
Geospatial
Apache 2.0
com.spatial4j » spatial4j 0.4.10.8
Reflection
Apache 2.0
commons-beanutils » commons-beanutils2 vulnerabilities 1.8.31.9.4
CLI Parser
Apache 2.0
commons-cli » commons-cli 1.21.5.0
Base64
Apache 2.0
commons-codec » commons-codec 1.91.15
Collections
Apache 2.0
commons-collections » commons-collections1 vulnerability 3.2.14.4
Config
Apache 2.0
commons-configuration » commons-configuration 1.62.8.0
Upload Manager
Apache 2.0
commons-fileupload » commons-fileupload4 vulnerabilities 1.2.11.4
I/O
Apache 2.0
commons-io » commons-io1 vulnerability 2.32.11.0
Core Utils
Apache 2.0
commons-lang » commons-lang 2.63.12.0
XML Processing
BSD 3-clause
dom4j » dom4j2 vulnerabilities 1.6.12.1.3
Date/Time
Apache 2.0
joda-time » joda-time 2.22.11.2
Logging
Apache 2.0
log4j » log4j4 vulnerabilities 1.2.172.19.0

BSD 3-clause
org.antlr » antlr-runtime 3.54.11.1
Annotation Lib
Apache 2.0
org.apache.hadoop » hadoop-annotations 2.2.03.3.4
Auth Lib
Apache 2.0
org.apache.hadoop » hadoop-auth 2.2.03.3.4

Apache 2.0
org.apache.hadoop » hadoop-common7 vulnerabilities 2.2.03.3.4
Dist FS
Apache 2.0
org.apache.hadoop » hadoop-hdfs 2.2.03.3.4
HTTP Clients
Apache 2.0
org.apache.httpcomponents » httpclient3 vulnerabilities 4.3.15.1.3
HTTP Clients
Apache 2.0
org.apache.httpcomponents » httpcore 4.35.1.4
MIME Types Lib
Apache 2.0
org.apache.httpcomponents » httpmime 4.3.14.5.13

Apache 2.0
org.apache.lucene » lucene-analyzers-common 4.9.08.11.2

Apache 2.0
org.apache.lucene » lucene-analyzers-kuromoji 4.9.08.11.2

Apache 2.0
org.apache.lucene » lucene-analyzers-phonetic 4.9.08.11.2

Apache 2.0
org.apache.lucene » lucene-codecs 4.9.09.4.0
Full-Text Indexing
Apache 2.0
org.apache.lucene » lucene-core 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-expressions 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-grouping 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-highlighter 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-join 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-memory 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-misc 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-queries 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-queryparser 4.9.09.4.0

Apache 2.0
org.apache.lucene » lucene-spatial 4.9.08.4.1

Apache 2.0
org.apache.lucene » lucene-suggest 4.9.09.4.0

Apache 2.0
org.apache.solr » solr-core8 vulnerabilities 4.9.09.0.0
Search Engine
Apache 2.0
org.apache.solr » solr-solrj 4.9.09.0.0
Template Engine
Apache 2.0
org.apache.velocity » velocity1 vulnerability 1.72.3

Apache 2.0
org.apache.velocity » velocity-tools1 vulnerability 2.03.1
Dist Coordination
Apache 2.0
org.apache.zookeeper » zookeeper3 vulnerabilities 3.4.63.8.0

Apache 2.0
org.codehaus.woodstox » wstx-asl 3.2.74.4.1

Apache 2.0EPL 1.0
org.eclipse.jetty » jetty-continuation 8.1.10.v201303129.4.49.v20220914

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-deploy 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-http1 vulnerability 8.1.10.v2013031211.0.12
I/O
Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-io1 vulnerability 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-jmx 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-security 8.1.10.v2013031211.0.12
Web Server
Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-server6 vulnerabilities 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-servlet 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-util 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-webapp1 vulnerability 8.1.10.v2013031211.0.12

Apache 2.0EPL 2.0
org.eclipse.jetty » jetty-xml 8.1.10.v2013031211.0.12

Apache 2.0EPL 1.0
org.eclipse.jetty.orbit » javax.servlet 3.0.0.v201112011016

Apache 2.0
org.noggit » noggit 0.50.8
Bytecode
BSD 3-clause
org.ow2.asm » asm 4.19.4

BSD 3-clause
org.ow2.asm » asm-commons 4.19.4

Apache 2.0CDDL 1.0EPL 1.0LGPL 3.0
org.restlet.jee » org.restlet 2.1.12.4.3

Apache 2.0CDDL 1.0EPL 1.0LGPL 3.0
org.restlet.jee » org.restlet.ext.servlet 2.1.12.4.3
Logging Bridge
MIT
org.slf4j » jul-to-slf4j (optional) 1.7.62.0.3
Logging
MIT
org.slf4j » slf4j-api 1.7.62.0.3
Logging Bridge
MIT
org.slf4j » slf4j-log4j12 (optional) 1.7.62.0.3

Test Dependencies (3)

Category/License Group / ArtifactVersionUpdates

Apache 2.0
org.apache.lucene » lucene-test-framework 4.9.09.4.0

Apache 2.0
org.apache.solr » solr-test-framework 4.9.09.0.0
Logging Bridge
Apache 2.0
org.slf4j » jcl-over-slf4j (optional) 1.7.62.0.3