The Bouncy Castle Java APIs for CMS, PKCS, EAC, TSP, CMP, CRMF, OCSP, and certificate generation. This jar contains APIs for JDK 1.8 and up. The APIs can be used in conjunction with a JCE/JCA provider such as the one provided with the Bouncy Castle Cryptography APIs.

LicenseBouncyCastle
Tagsjdk
HomePage https://www.bouncycastle.org/java.html
DateSep 29, 2022
Filespom (1 KB)  jar (985 KB)  View All
RepositoriesCentral
Ranking#693 in MvnRepository (See Top Artifacts)
Used By688 artifacts
VulnerabilitiesDirect vulnerabilities:
CVE-2023-33202

Vulnerabilities from dependencies:
CVE-2023-33202
CVE-2023-33201

Note: There is a new version for this artifact

New Version1.77


Compile Dependencies (2)

Category/License Group / ArtifactVersionUpdates

BouncyCastle
org.bouncycastle » bcprov-jdk18on2 vulnerabilities 1.721.77

BouncyCastle
org.bouncycastle » bcutil-jdk18on 1.721.77

Licenses

LicenseURL
Bouncy Castle Licence https://www.bouncycastle.org/licence.html

Developers

NameEmailDev IdRolesOrganization
The Legion of the Bouncy Castle Inc.feedback-crypto<at>bouncycastle.orgfeedback-crypto