A dependency-free HTTP/HTTPS intercepting proxy built on blocking I/O and virtual threads (Project Loom). A port of LittleProxy without Netty.

Compile Dependencies (4)

Category/LicenseGroup / ArtifactVersionUpdates
Apache 2.0
io.github.mahmoudimus » zstd-decoder(optional)
A pure-Java Zstandard (RFC 8878) decoder with no dependencies and no Unsafe, for JDK 21 and newer.
0.3.00.4.0
Apache 2.0
io.github.mahmoudimus » http2-codec(optional)
A dependency-free HTTP/2 (RFC 9113) frame codec and HPACK (RFC 7541) implementation for
0.3.00.4.0
Apache 2.0
io.github.mahmoudimus » http3-codec(optional)
A dependency-free HTTP/3 (RFC 9114) frame codec and QPACK (RFC 9204) implementation for
0.3.00.4.0
Apache 2.0
io.github.mahmoudimus » quic(optional)
A dependency-free QUIC (RFC 9000, RFC 9001, RFC 9002) implementation for JDK 21 and newer:
0.3.00.4.0

Test Dependencies (1)

Category/LicenseGroup / ArtifactVersionUpdates
Testing EPL 2.0
org.junit.jupiter » junit-jupiter
Module "junit-jupiter" of JUnit
5.11.46.1.3