This is an implementation of DG Execute Node that makes a call to an external REST API

Compile Dependencies (0)

Category/LicenseGroup / ArtifactVersionUpdates

Managed Dependencies (355)

Category/LicenseGroup / ArtifactVersionUpdates
Logging EPL 2.0 +1
ch.qos.logback » logback-classic1 vulnerability
Implementation of the SLF4J API for Logback, a reliable, generic, fast and flexible logging framework.
1.2.31.6.5
Logging EPL 2.0 +1
ch.qos.logback » logback-core8 vulnerabilities
Core implementation of Logback, a reliable, generic, fast and flexible logging framework.
1.2.31.6.5
Apache 2.0 +1
ch.vorburger.mariaDB4j » mariaDB4j2.2.33.3.1
BSD
com.att.eelf » eelf-core
The Generic logging framework
1.0.02.0.0-oss
Collections Apache 2.0
com.carrotsearch » hppc
High Performance Primitive Collections: data structures (maps, sets, lists, stacks, queues) generated for combinations ...
0.7.10.12.0
Bill of materials Apache 2.0
com.fasterxml.jackson » jackson-bom
Bill of Materials pom for getting full, complete set of compatible versions
2.8.11.201811233.2.4
CPAL 1.0 +1
com.github.stefanbirkner » system-rules
A collection of JUnit rules for testing code which uses java.lang.System.
1.19.0✔
Mocking Apache 2.0
com.github.tomakehurst » wiremock
A web service test double for all occasions
2.7.13.13.2
JSON Lib Apache 2.0
com.google.code.gson » gson1 vulnerability
Gson is a Java library that can be used to convert Java Objects into their JSON representation. It can also be used to ...
2.8.52.14.0
Data Format BSD 3-clause
com.google.protobuf » protobuf-java6 vulnerabilities
Core Protocol Buffers library. Protocol Buffers are a way of encoding structured data in an
3.6.14.36.2
JSON Lib Apache 2.0
com.jayway.jsonpath » json-path1 vulnerability
A library to query and verify JSON
2.3.03.0.0
Compression Apache 2.0
com.ning » compress-lzf
Compression codec for LZF encoding for particularly encoding/decoding, with reasonable compression.
1.0.21.2.1
Geospatial Apache 2.0
com.spatial4j » spatial4j
Spatial4j is a general purpose spatial / geospatial ASL licensed open-source Java library. It's
0.50.8
Apache 2.0
com.tdunning » t-digest
Data structure which allows accurate estimation of quantiles and related rank statistics
3.03.3
Concurrency CC0 1.0
com.twitter » jsr166e
JSR166e
1.1.0✔
CLI Parser Apache 2.0
commons-cli » commons-cli
Apache Commons CLI provides a simple API for presenting, processing, and validating a Command Line Interface.
1.3.11.11.0
Collections Apache 2.0
commons-collections » commons-collections
The Apache Commons Collections package contains types that extend and augment the Java Collections Framework.
3.2.24.6.0
I/O Apache 2.0
commons-io » commons-io2 vulnerabilities
The Apache Commons IO library contains utility classes, stream implementations, file filters,
2.52.22.0
Logging Apache 2.0
commons-logging » commons-logging
Apache Commons Logging is a thin adapter allowing configurable bridging to other,
1.21.4.0
XML Processing BSD 3-clause
dom4j » dom4j2 vulnerabilities
flexible XML framework for Java
1.6.12.2.0
Dist Communication Apache 2.0
io.grpc » grpc-netty
gRPC: Netty
1.17.11.85.1
Serializer Apache 2.0
io.grpc » grpc-protobuf
gRPC: Protobuf
1.17.11.85.1
Dist Communication Apache 2.0
io.grpc » grpc-stub
Stub classes for GRPC which are exposed to developers and provides type-safe bindings.
1.17.11.85.1
Testing Apache 2.0
io.grpc » grpc-testing
gRPC: Testing
1.17.11.85.1
jakarta-regexp » jakarta-regexp1.4✔
Java Spec EPL 2.0 +1
javax » javaee-api7.011.0.0
Java Spec CDDL +2
javax.servlet » servlet-api
Java Servlet is the foundation web specification in the Java Enterprise Platform. Developers can build web applications ...
2.54.0.1
Date/Time Apache 2.0
joda-time » joda-time
Joda-Time provides a quality replacement for the Java date and time classes. Note that from Java SE 8 onwards, users ...
2.8.22.15.0
Testing EPL 2.0
junit » junit1 vulnerability
JUnit Jupiter is the API for writing tests using JUnit 5.
4.126.1.3
I/O Apache 2.0
org.apache.commons » commons-io1 vulnerability
The Apache Commons IO library contains utility classes, stream implementations, file filters,
1.3.22.22.0
Core Utils Apache 2.0
org.apache.commons » commons-lang31 vulnerability
Apache Commons Lang, a package of Java utility classes for the classes that are in java.lang's hierarchy, or are ...
3.43.21.0
String Utils Apache 2.0
org.apache.commons » commons-text
The Commons Text library provides additions to the standard JDK text handling. It includes algorithms for string ...
1.11.15.0
Embedded SQL DB Apache 2.0
org.apache.derby » derby1 vulnerability
Contains the core Apache Derby database engine, which also includes the embedded JDBC driver.
10.14.2.010.17.1.0
HTTP Clients Apache 2.0
org.apache.httpcomponents » httpcore
Apache HttpComponents HTTP/1.1 core components
4.4.45.4.4
HTTP Clients Apache 2.0
org.apache.httpcomponents » httpclient1 vulnerability
Apache HttpComponents Client
4.5.25.6.5
Apache 2.0
org.apache.lucene » lucene-analyzers-common
Apache Lucene (module: common)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-backward-codecs
Apache Lucene (module: backward-codecs)
5.4.110.5.2
Full-Text Indexing Apache 2.0
org.apache.lucene » lucene-core
Apache Lucene (module: core)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-grouping
Apache Lucene (module: grouping)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-highlighter
Apache Lucene (module: highlighter)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-join
Apache Lucene (module: join)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-memory
Apache Lucene (module: memory)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-misc
Apache Lucene (module: misc)
5.4.110.5.2
Full-Text Indexing Apache 2.0
org.apache.lucene » lucene-queries
Apache Lucene (module: queries)
5.4.110.5.2
Full-Text Indexing Apache 2.0
org.apache.lucene » lucene-queryparser
Apache Lucene (module: queryparser)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-sandbox
Apache Lucene (module: sandbox)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-spatial
Apache Lucene (module: spatial-extras)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-spatial3d
Apache Lucene (module: spatial3d)
5.4.110.5.2
Apache 2.0
org.apache.lucene » lucene-suggest
Apache Lucene (module: suggest)
5.4.110.5.2
Apache 2.0
org.apache.sling » org.apache.sling.testing.osgi-mock2.3.23.5.8
SSH Lib Apache 2.0
org.apache.sshd » sshd-core1 vulnerability 0.12.02.20.0
JDBC Pool Apache 2.0
org.apache.tomcat » tomcat-jdbc
Tomcat JDBC Pool Package
8.5.1411.0.27
Template Engine Apache 2.0
org.apache.velocity » velocity1 vulnerability
Core module of Apache Velocity, a Java-based template engine for generating text output.
1.72.4.1
Apache 2.0
org.codehaus.jackson » jackson-jaxrs
Functionality to handle JSON input/output for JAX-RS implementations (like Jersey and RESTeasy) using standard Jackson ...
1.9.132.22.4
Apache 2.0 +1
org.eclipse.jetty » jetty-servlet
Jetty Servlet Container
9.3.24.v2018060512.1.14
WebSocket Clients Apache 2.0 +1
org.eclipse.jetty.websocket » websocket-api9.3.24.v201806059.4.58.v20250814
Apache 2.0 +1
org.eclipse.jetty.websocket » websocket-servlet9.3.24.v2018060511.0.26
org.elasticsearch » elasticsearch14 vulnerabilities
Elasticsearch subproject :server
2.2.09.5.5
Apache 2.0
org.elasticsearch » securesm
SecurityManager implementation that works around design flaws in Java
1.01.2
Apache 2.0
org.elasticsearch.plugin » delete-by-query2.2.02.4.6
Bill of materials EPL 2.0 +1
org.glassfish.jersey » jersey-bom
Jersey Bill of Materials (BOM)
2.25.14.0.3
Application Metrics BSD 2-clause +1
org.hdrhistogram » HdrHistogram
HdrHistogram supports the recording and analyzing sampled data value
2.1.62.2.2
org.java-websocket » Java-WebSocket1 vulnerability
A barebones WebSocket client and server implementation written 100% in Java
1.3.81.6.0
String Utils Apache 2.0
org.joda » joda-convert
Library to convert Objects to and from String, compatible with Java 21+
1.23.0.1
org.jsoup » jsoup3 vulnerabilities
jsoup is a Java library that simplifies working with real-world HTML and XML. It offers an easy-to-use API for URL ...
1.8.31.23.2
JDBC Driver LGPL 2.1
org.mariadb.jdbc » mariadb-java-client4 vulnerabilities
JDBC driver for MariaDB and MySQL
2.1.14.0.0
Mocking MIT
org.mockito » mockito-core
Mockito mock objects library core API and implementation
2.2.115.24.0
EPL 1.0
org.opendaylight.controller » sal-binding-broker-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-binding-broker-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-test-model1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-common-api1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-common-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-common-util1.8.213.0.5
EPL 1.0
org.opendaylight.controller » sal-core-api1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-core-spi1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-core-compat1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-broker-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-binding-api1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-binding-util1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-connector-api1.8.21.9.3
EPL 1.0
org.opendaylight.controller » sal-inmemory-datastore1.8.21.11.3
EPL 1.0
org.opendaylight.controller » mdsal-trace-api1.8.21.11.3
EPL 1.0
org.opendaylight.controller » mdsal-trace-dom-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » mdsal-trace-binding-impl1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-test-model1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-binding-it1.8.214.0.4
EPL 1.0
org.opendaylight.controller » features-mdsal1.8.21.11.3
org.opendaylight.controller » features-restconf1.8.2✔
EPL 1.0
org.opendaylight.controller » features-mdsal-trace1.8.21.11.3
EPL 1.0
org.opendaylight.controller » sal-clustering-commons
Common clustering utilities
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-commons
Common clustering utilities
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-config
Configuration files for md-sal clustering
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-distributed-datastore1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-remoterpc-connector
Gossip-based MD-SAL Action/RPC routing in Pekko clusters
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft
Pekko-based RAFT implementation
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft
Pekko-based RAFT implementation
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft-example1.8.214.0.4
EPL 1.0
org.opendaylight.controller » cds-access-api
CDS frontend APIs for backend access
1.4.214.0.4
EPL 1.0
org.opendaylight.controller » cds-access-client
Clustered Data Store client infrastructure
1.4.214.0.4
EPL 1.0
org.opendaylight.controller » cds-access-client
Clustered Data Store client infrastructure
1.4.214.0.4
EPL 1.0
org.opendaylight.controller » sal-cluster-admin-api1.8.214.0.4
EPL 1.0
org.opendaylight.controller » sal-cluster-admin-impl1.8.214.0.4
EPL 1.0
org.opendaylight.controller » cds-dom-api
DOM APIs exposed by CDS
1.4.214.0.4
EPL 1.0
org.opendaylight.controller » messagebus-api1.8.23.0.16
EPL 1.0
org.opendaylight.controller » messagebus-spi1.8.23.0.16
EPL 1.0
org.opendaylight.controller » messagebus-impl1.8.23.0.16
EPL 1.0
org.opendaylight.controller » messagebus-util1.8.23.0.16
EPL 1.0
org.opendaylight.controller » odl-mdsal-broker
OpenDaylight Controller stack with clustering
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-broker-local
OpenDaylight Controller stack without clustering
1.8.23.0.16
EPL 1.0
org.opendaylight.controller » odl-mdsal-clustering1.8.21.11.3
EPL 1.0
org.opendaylight.controller » odl-mdsal-clustering-commons
Common Clustering utilities
1.8.213.0.5
EPL 1.0
org.opendaylight.controller » odl-controller-mdsal-common1.8.214.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-distributed-datastore
Controller Clustered Datastore (akka-based)
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-remoterpc-connector
Clustering remote RPC support
1.8.213.0.5
EPL 1.0
org.opendaylight.controller » odl-message-bus-collector1.8.21.11.3
EPL 1.0
org.opendaylight.controller » odl-mdsal-model-inventory1.8.23.0.16
EPL 1.0
org.opendaylight.controller » odl-controller-model-topology1.8.23.0.16
EPL 1.0
org.opendaylight.controller » odl-toaster
The venerable Toaster
1.8.214.0.4
EPL 1.0
org.opendaylight.controller » odl-clustering-test-app1.8.214.0.4
EPL 1.0
org.opendaylight.controller.model » model-inventory1.8.23.0.16
EPL 1.0
org.opendaylight.controller.model » model-topology1.8.23.0.16
EPL 1.0
org.opendaylight.controller.samples » sample-toaster1.8.214.0.4
EPL 1.0
org.opendaylight.controller.samples » sample-toaster-consumer1.8.214.0.4
EPL 1.0
org.opendaylight.controller.samples » sample-toaster-provider1.8.214.0.4
EPL 1.0
org.opendaylight.controller.samples » toaster-config
Configuration files for toaster
1.8.2✔
org.opendaylight.controller.samples » features-toaster1.8.2
EPL 1.0
org.opendaylight.controller.samples » clustering-it-config1.8.214.0.4
EPL 1.0
org.opendaylight.controller.samples » clustering-it-model1.8.214.0.4
EPL 1.0
org.opendaylight.controller.samples » clustering-it-provider1.8.214.0.4
EPL 1.0
org.opendaylight.mdsal » features-mdsal
MD-SAL stable feature repository
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-common-api
MD-SAL common APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-common-util2.5.27.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-api
MD-SAL DOM APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-spi
MD-SAL DOM service provider interfaces
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-broker
MD-SAL core implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-schema-service-osgi2.5.25.0.17
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-inmemory-datastore2.5.216.0.6
EPL 1.0
org.opendaylight.mdsal » maven-sal-api-gen-plugin0.13.27.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-api0.13.27.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-util0.13.27.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-impl0.13.27.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-java-api-generator0.13.213.0.10
EPL 1.0
org.opendaylight.mdsal » yang-binding
Java binding for YANG
0.13.213.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-spec-util0.13.213.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec0.13.213.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec-osgi0.13.213.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-api
MD-SAL Binding APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-adapter
MD-SAL Binding implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-adapter
MD-SAL Binding implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-spi
MD-SAL Binding API helper classes
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-util
MD-SAL Binding utility APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-test-utils2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-test-model
mdsal-binding-test-model
0.13.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-maven-api-gen-plugin0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-runtime0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-dom-codec0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-api0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-dom-adapter0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-spi0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-test-model
mdsal-binding2-test-model
0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-generator-api0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-spec
Java Binding for YANG
0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-generator-impl0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-java-api-generator0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-generator-util0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-binding2-util
mdsal-binding2-util
0.13.20.15.16
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-common-api
Entity Ownership Service common APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-common-spi2.5.212.0.8
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-dom-api
Entity Ownership Service DOM APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-dom-simple
Entity Ownership Service (single-node)
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-binding-api
Entity Ownership Service Binding APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-binding-adapter
Entity Ownership Service Binding implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-singleton-common-api2.5.212.0.8
EPL 1.0
org.opendaylight.mdsal » mdsal-singleton-dom-impl2.5.212.0.8
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding
MD-SAL full Java Binding functionality
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-base
MD-SAL Java Binding base support
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-runtime
MD-SAL Java Binding runtime
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-api
MD-SAL Java Binding APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-dom-adapter
MD-SAL Java Binding/DOM adapter
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding2
MD-SAL full Java Binding 2 functionality (experimental)
2.5.23.0.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding2-base
MD-SAL Java Binding 2 base support (experimental)
2.5.23.0.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding2-runtime
MD-SAL Java Binding 2 runtime (experimental)
2.5.23.0.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding2-api
MD-SAL Java Binding 2 APIs (experimental)
2.5.23.0.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding2-dom-adapter
MD-SAL Java Binding 2/DOM adapter (experimental)
2.5.23.0.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom
MD-SAL full DOM functionality
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom-api
MD-SAL DOM APIs
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom-broker
MD-SAL DOM implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-common
MD-SAL common APIs and utilities
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-common
Entity Ownership Service common API
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-dom
Entity Ownership Service DOM API
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-binding
Entity Ownership Service Binding support
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-singleton-common
MD-SAL Cluster Singleton Service commons
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-singleton-dom
MD-SAL Cluster Singleton Service implementation
2.5.217.0.2
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » iana-routing-types
iana-routing-types@2021-10-19
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » iana-hardware
iana-hardware@2018-03-13
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc7952
RFC7952 YANG Metadata
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8294
RFC8294 Common YANG Data Types for the Routing Area
1.0.211.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8294-ietf-routing-types
RFC8294 ietf-routing-types
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342
RFC8342 Network Management Datastore Architecture
1.0.211.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342-ietf-datastores
RFC8342 ietf-datastores
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342-ietf-origin
RFC8342 ietf-origin
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8343
RFC8343 Interface Management
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8344
RFC8343 IP Management
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345
RFC8345 Network Topologies
1.0.211.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network
RFC8345 ietf-network
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-state
RFC8345 ietf-network for non-NMDA
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-topology
RFC8345 ietf-network-topology
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-topology-state
RFC8345 ietf-network-topology for non-NMDA
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348
RFC8348 Hardware Management
1.0.211.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348-ietf-hardware
RFC8348 ietf-hardware
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348-ietf-hardware-state
RFC8348 ietf-hardware-state
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349
RFC8349 Routing Management
1.0.211.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-routing
RFC8349 ietf-routing
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-ipv4-unicast-routing
RFC8349 ietf-ipv4-unicast-routing
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-ipv6-unicast-routing
RFC8349 ietf-ipv6-unicast-routing
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » yang-ext
yang-ext
2013.09.07.13.22013.09.07.29.2
EPL 1.0
org.opendaylight.mdsal.model » general-entity
general-entity
0.13.217.0.2
EPL 1.0
org.opendaylight.mdsal.model » opendaylight-l2-types2013.08.27.13.22013.08.27.29.2
EPL 1.0
org.opendaylight.mdsal.model » ietf-inet-types-2013-07-15
ietf-inet-types-2013-07-15
1.5.21.5.3
EPL 1.0
org.opendaylight.mdsal.model » ietf-yang-types-20130715
ietf-yang-types-20130715
2013.07.15.13.22013.07.15.13.3
EPL 1.0
org.opendaylight.mdsal.model » ietf-type-util2.1.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » ietf-interfaces
ietf-interfaces
2014.05.08.13.22014.05.08.13.3
EPL 1.0
org.opendaylight.mdsal.model » iana-if-type-2014-05-08
iana-if-type-2014-05-08
2014.05.08.13.22014.05.08.13.3
EPL 1.0
org.opendaylight.mdsal.model » ietf-ip-2014-06-16
ietf-ip-2014-06-16
2014.06.16.13.22014.06.16.13.3
EPL 1.0
org.opendaylight.mdsal.model » rfc7895
YANG Module Library model
1.0.21.0.3
EPL 1.0
org.opendaylight.mdsal.model » ietf-restconf
ietf-restconf
2013.10.19.13.22013.10.19.16.17
EPL 1.0
org.opendaylight.mdsal.model » ietf-ted
ietf-ted
2013.10.21.13.22013.10.21.18.12
EPL 1.0
org.opendaylight.mdsal.model » ietf-topology
ietf-topology
2013.10.21.13.22013.10.21.29.2
EPL 1.0
org.opendaylight.mdsal.model » ietf-topology-isis
ietf-topology-isis
2013.10.21.13.22013.10.21.18.12
EPL 1.0
org.opendaylight.mdsal.model » ietf-topology-l3-unicast-igp
ietf-topology-l3-unicast-igp
2013.10.21.13.22013.10.21.18.12
EPL 1.0
org.opendaylight.mdsal.model » ietf-topology-ospf
ietf-topology-ospf
2013.10.21.13.22013.10.21.18.12
org.opendaylight.mdsal.model » ietf-topology-l3-unicast2013.10.21.13.2
EPL 1.0
org.opendaylight.mdsal.model » ietf-lisp-address-types-2015-11-05
ietf-lisp-address-types-2015-11-05
1.2.23.0.17
EPL 1.0
org.opendaylight.mdsal.model » ietf-packet-fields
ietf-packet-fields
0.11.20.15.17
EPL 1.0
org.opendaylight.mdsal.model » ietf-access-control-list
ietf-access-control-list
0.11.20.15.17
EPL 1.0
org.opendaylight.mdsal.model » iana-afn-safi2013.07.04.13.22013.07.04.17.17
EPL 1.0
org.opendaylight.mdsal.model » features-mdsal-model0.13.20.13.3
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc6991
Models from RFC6991
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7223
Models from RFC7223
1.0.28.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7224
Models from RFC7224
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7277
Models from RFC7277
1.0.28.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7895
Models from RFC7895
1.0.28.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7952
Models from RFC7952
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8294
Models from RFC8294
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8342
Models from RFC8342
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8343
Models from RFC8343
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8344
Models from RFC8344
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8345
NMDA models from RFC8345
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8345-non-nmda
Non-NMDSA models from RFC8345
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8348
NMDA models from RFC8348
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8348-non-nmda
Non-NMDA models from RFC8348
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8349
Models from RFC8349
1.0.214.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-bierman-netconf-restconf-02
Models from draft-bierman-netconf-restconf-02
1.0.22.0.17
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-clemm-netmod-yang-network-topo-01
Models from draft-clemm-netmod-yang-network-topo-01
1.0.26.0.12
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-clemm-netmod-yang-network-topo-01-minimal
Models from draft-clemm-netmod-yang-network-topo-01 (minimal)
1.0.217.0.2
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-ietf-lisp-lcaf-10
Models from draft-ietf-lisp-yang-06
1.0.23.0.17
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-ietf-netmod-acl-model-07
Models from draft-ietf-netmod-acl-model-07
1.0.23.0.17
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-ietf-netmod-iana-afn-safi-00
Models from draft-ietf-netmod-iana-afn-safi-00
1.0.23.0.17
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-odl-l2-types
OpenDaylight-specific model of Layer 2 types
1.0.217.0.2
EPL 1.0
org.opendaylight.mdsal.model.binding2 » yang-ext
yang-ext
2013.09.07.13.22013.09.07.15.16
EPL 1.0
org.opendaylight.netconf » aaa-authn-odl-plugin1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-api
NETCONF API
1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-auth1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-cli1.5.2✔
EPL 1.0
org.opendaylight.netconf » netconf-client
NETCONF client
1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-config
Global threadpools for NETCONF
1.5.26.0.9
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-connector1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-impl1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-mapping-api1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-monitoring1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-monitoring1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-yang-library1.5.26.0.9
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-impl1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-netty-util1.5.211.0.2
EPL 1.0
org.opendaylight.netconf » netconf-ssh1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » netconf-tcp1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » netconf-testtool1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-util1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-util1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » sal-netconf-connector1.8.25.0.10
EPL 1.0
org.opendaylight.netconf » messagebus-netconf1.5.21.13.8
EPL 1.0
org.opendaylight.netconf » ietf-netconf1.5.23.0.9
EPL 1.0
org.opendaylight.netconf » ietf-netconf-monitoring1.5.23.0.9
EPL 1.0
org.opendaylight.netconf » ietf-netconf-monitoring-extension1.5.23.0.9
EPL 1.0
org.opendaylight.netconf » ietf-netconf-notifications1.5.23.0.9
EPL 1.0
org.opendaylight.netconf » yanglib1.5.27.0.2
EPL 1.0
org.opendaylight.netconf » callhome-protocol1.5.26.0.9
EPL 1.0
org.opendaylight.netconf » callhome-model1.5.26.0.9
EPL 1.0
org.opendaylight.netconf » callhome-provider1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-notifications-api1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-notifications-impl1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-notification1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-ssh1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » mdsal-netconf-tcp1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-topology
NETCONF topology SPIs
1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-topology-config
Configuration files for netconf topology
1.5.21.8.3
EPL 1.0
org.opendaylight.netconf » netconf-client
NETCONF client
1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » netconf-impl1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-netty-util1.5.211.0.2
EPL 1.0
org.opendaylight.netconf » netconf-ssh1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » netconf-util1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » netconf-topology-singleton1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » protocol-framework
Common protocol framework
1.2.21.2.3
EPL 1.0
org.opendaylight.netconf » shaded-exificient1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » features-protocol-framework1.2.21.2.3
EPL 1.0
org.opendaylight.netconf » odl-protocol-framework1.2.21.2.3
EPL 1.0
org.opendaylight.netconf » features-netconf1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-aaa-netconf-plugin1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-aaa-netconf-plugin-no-cluster1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-all1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-api1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-client1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-impl1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-mapping-api1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-mdsal1.8.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-monitoring1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » odl-netconf-netty-util1.5.26.0.9
EPL 1.0
org.opendaylight.netconf » odl-netconf-notifications-api1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-notifications-impl1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-ssh1.5.28.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-tcp1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-netconf-util1.5.28.0.10
EPL 1.0
org.opendaylight.netconf » features-netconf-connector1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-message-bus1.5.21.13.8
EPL 1.0
org.opendaylight.netconf » odl-netconf-clustered-topology1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-connector1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-connector-all1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-connector-ssh1.5.21.5.3
EPL 1.0
org.opendaylight.netconf » odl-netconf-callhome-ssh1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-console1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-netconf-topology1.5.212.0.2
EPL 1.0
org.opendaylight.netconf » features-yanglib1.5.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-yanglib1.5.27.0.2
EPL 1.0
org.opendaylight.netconf » ietf-restconf1.8.22.0.17
EPL 1.0
org.opendaylight.netconf » ietf-restconf-monitoring1.8.23.0.9
EPL 1.0
org.opendaylight.netconf » restconf-common-models1.8.27.0.12
EPL 1.0
org.opendaylight.netconf » restconf-common1.8.27.0.12
EPL 1.0
org.opendaylight.netconf » restconf-nb-bierman021.8.23.0.9
EPL 1.0
org.opendaylight.netconf » restconf-nb-rfc80401.8.23.0.9
EPL 1.0
org.opendaylight.netconf » sal-rest-connector-config
Configuration files for sal-rest-connector
1.8.27.0.12
EPL 1.0
org.opendaylight.netconf » sal-rest-docgen1.8.25.0.10
EPL 1.0
org.opendaylight.netconf » sal-rest-docgen-maven1.8.21.13.8
org.opendaylight.netconf » sal-restconf-broker1.8.2
EPL 1.0
org.opendaylight.netconf » features-restconf1.8.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-mdsal-apidocs1.8.25.0.10
EPL 1.0
org.opendaylight.netconf » odl-restconf1.8.211.0.2
EPL 1.0
org.opendaylight.netconf » odl-restconf-all1.8.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-restconf-common1.8.212.0.2
EPL 1.0
org.opendaylight.netconf » odl-restconf-noauth1.8.21.9.3
Mocking Apache 2.0
org.powermock » powermock-api-mockito2
PowerMock API for Mockito 2.+..
1.6.62.0.9
Mocking Apache 2.0
org.powermock » powermock-module-junit4
PowerMock support module for JUnit 4.x.
1.6.62.0.9
Logging Bridge Apache 2.0
org.slf4j » jcl-over-slf4j
Jakarta/Apache commons logging 1.2 implemented over SLF4J
1.7.252.0.20
Bill of materials Apache 2.0
org.springframework » spring-framework-bom1 vulnerability
Spring Framework (Bill of Materials)
4.3.18.RELEASE7.0.9
Testing Apache 2.0
org.testng » testng
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more ...
6.117.12.0
YAML Apache 2.0
org.yaml » snakeyaml8 vulnerabilities
YAML 1.1 parser and emitter for Java
1.152.7