Bundle Parent

Compile Dependencies (0)

Category/LicenseGroup / ArtifactVersionUpdates

Managed Dependencies (603)

Category/LicenseGroup / ArtifactVersionUpdates
Logging EPL 2.0 +1
ch.qos.logback » logback-core8 vulnerabilities
Core implementation of Logback, a reliable, generic, fast and flexible logging framework.
1.2.31.6.5
Logging EPL 2.0 +1
ch.qos.logback » logback-classic1 vulnerability
Implementation of the SLF4J API for Logback, a reliable, generic, fast and flexible logging framework.
1.2.31.6.5
Annotation Lib Apache 2.0
com.fasterxml.jackson.core » jackson-annotations
Core annotations used for value types, used by Jackson data binding package.
2.10.42.22
JSON Lib Apache 2.0
com.fasterxml.jackson.core » jackson-core2 vulnerabilities
Core Jackson processing abstractions (aka Streaming API), implementation for JSON
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.core » jackson-databind14 vulnerabilities
General data-binding functionality for Jackson: works on core streaming API
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-avro
Support for reading and writing AVRO-encoded data via Jackson
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-cbor1 vulnerability
Support for reading and writing Concise Binary Object Representation
2.10.43.2.3
CSV Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-csv
Support for reading and writing CSV-encoded data via Jackson
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-ion
Support for reading and writing Ion ("binary JSON")
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-properties
Support for reading and writing content of "Java Properties" style
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-protobuf
Support for reading and writing protobuf-encoded data via Jackson
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-smile
Support for reading and writing Smile ("binary JSON")
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-xml
Data format extension for Jackson to offer
2.10.43.2.3
Data Format Apache 2.0
com.fasterxml.jackson.dataformat » jackson-dataformat-yaml
Support for reading and writing YAML-encoded data via Jackson abstractions.
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-guava
Add-on datatype-support module for Jackson (https://github.com/FasterXML/jackson) that handles
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-hibernate3
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.42.22.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-hibernate4
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-hibernate5
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-hppc
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-jaxrs
Functionality for reading/writing core JAX-RS helper types
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-joda
Add-on module for Jackson (http://github.com/FasterXML/jackson) to support
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-jdk8
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.42.22.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-json-org
Support for datatypes of "org.json" JSON library (see http://json.org/java),
2.10.43.2.3
Date/Time Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-jsr310
Add-on module to support JSR-310 (Java 8 Date & Time API) data types.
2.10.43.0.0-rc2
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-jsr353
Add-on module for Jackson (http://github.com/FasterXML/jackson) to support
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.datatype » jackson-datatype-pcollections
Add-on datatype-support module for Jackson (https://github.com/FasterXML/jackson) that handles
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-base
Pile of code that is shared by all Jackson-based JAX-RS
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-cbor-provider
Functionality to handle CBOR encoded input/output for JAX-RS implementations (like Jersey and RESTeasy) using standard ...
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-json-provider
Functionality to handle JSON input/output for JAX-RS implementations (like Jersey and RESTeasy) using standard Jackson ...
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-smile-provider
Functionality to handle Smile (binary JSON) input/output for JAX-RS implementations (like Jersey and RESTeasy) using ...
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-xml-provider
Functionality to handle XML input/output for JAX-RS implementations (like Jersey and RESTeasy) using standard Jackson ...
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jaxrs » jackson-jaxrs-yaml-provider
Functionality to handle YAML input/output for JAX-RS implementations (like Jersey and RESTeasy)
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jr » jackson-jr-all
"Uber" jar that contains all Jackson jr components as well as underlying Jackson core
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jr » jackson-jr-objects
Simple data-binding that builds directly on jackson-core (streaming),
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jr » jackson-jr-retrofit2
Basic provider implementation for Retrofit 2 library
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.jr » jackson-jr-stree
Simple immutable (read-only) tree model that builds directly on jackson-core (streaming),
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.module » jackson-module-afterburner
Jackson (https://github.com/FasterXML/jackson) extension module
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.module » jackson-module-guice
Stuff to make integration with Guice a bit easier
2.10.43.2.3
Annotation Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-jaxb-annotations
Support for using JAXB annotations as an alternative to "native" Jackson annotations,
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-jsonSchema
Add-on module for Jackson (http://jackson.codehaus.org) to support
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-kotlin
Add-on module for Jackson (https://github.com/FasterXML/jackson/) to support
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.module » jackson-module-mrbean
Functionality for implementing interfaces and abstract types
2.10.43.2.3
Apache 2.0
com.fasterxml.jackson.module » jackson-module-osgi
Jackson module to inject OSGI services in deserialized beans.
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-parameter-names
Add-on module for Jackson (https://github.com/FasterXML/jackson) to support
2.10.42.22.3
Apache 2.0
com.fasterxml.jackson.module » jackson-module-paranamer
AnnotationIntrospectors that use Paranamer (http://paranamer.codehaus.org)
2.10.42.22.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-scala_2.10
jackson-module-scala
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-scala_2.11
jackson-module-scala
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-scala_2.12
jackson-module-scala
2.10.43.2.3
JSON Lib Apache 2.0
com.fasterxml.jackson.module » jackson-module-scala_2.13
jackson-module-scala
2.10.43.2.3
XML Processing Apache 2.0
com.fasterxml.woodstox » woodstox-core1 vulnerability
Woodstox is a high-performance XML processor that implements Stax (JSR-173),
6.2.17.3.0
com.github.spotbugs » spotbugs-annotations(optional)
Annotations the SpotBugs tool supports
3.1.124.10.4
JSON Lib Apache 2.0
com.google.code.gson » gson1 vulnerability
Gson is a Java library that can be used to convert Java Objects into their JSON representation. It can also be used to ...
2.8.52.14.0
Defect Detection Apache 2.0
com.google.errorprone » error_prone_annotations
Annotations for Error Prone, a static analysis tool for Java that catches common programming mistakes at compile-time.
2.3.42.50.0
Core Utils Apache 2.0
com.google.guava » guava2 vulnerabilities
Guava is a suite of core and expanded libraries that include
29.0-jre33.7.2-jre
Testing Apache 2.0
com.google.guava » guava-testlib
Guava testlib is a set of java classes used for more convenient
29.0-jre33.7.2-jre
Assertion Apache 2.0
com.google.truth » truth
Fluent assertions for Java and Android that makes your test assertions and failure messages more readable.
1.0.11.4.5
Apache 2.0
com.google.truth.extensions » truth-java8-extension
Obsolete, empty artifact that merely pulls in the main `truth` artifact: Assertions for Java 8 types are now part of ...
1.0.11.4.5
Embedded SQL DB EPL 1.0 +1
com.h2database » h24 vulnerabilities
A fast SQL database that can run embedded or a server mode with support for transactions, encryption, full search, etc. ...
1.4.2002.5.252
Concurrency Apache 2.0
com.lmax » disruptor
Disruptor - Concurrent Programming Framework
3.4.24.0.0
Code Analyzer LGPL 2.1
com.puppycrawl.tools » checkstyle
Checkstyle is a development tool to help programmers write Java code
8.36.114.3.0
Config Apache 2.0
com.typesafe » config
configuration library for JVM languages using HOCON files
1.3.31.4.3
Apache 2.0
com.typesafe » ssl-config-core_2.13
ssl-config-core
0.3.80.6.1
Testing BUSL 1.1
com.typesafe.akka » akka-testkit_2.13
Akka is a toolkit for building highly concurrent, distributed, and resilient message-driven applications for Java and ...
2.5.312.10.9
BUSL 1.1
com.typesafe.akka » akka-persistence-tck_2.13
Akka is a toolkit for building highly concurrent, distributed, and resilient message-driven applications for Java and ...
2.5.312.10.9
Apache 2.0
com.webcohesion.enunciate » enunciate-core-annotations
Enunciate core annotations.
2.13.12.20.0
Reflection Apache 2.0
commons-beanutils » commons-beanutils1 vulnerability
Apache Commons BeanUtils provides an easy-to-use but flexible wrapper around reflection and introspection.
1.9.41.11.0
Base64 Apache 2.0
commons-codec » commons-codec
The Apache Commons Codec component contains encoders and decoders for
1.151.22.1
Upload Manager Apache 2.0
commons-fileupload » commons-fileupload2 vulnerabilities
The Apache Commons FileUpload Javax component provides a simple yet flexible means of adding support for multipart
1.42.0.0-M5
I/O Apache 2.0
commons-io » commons-io1 vulnerability
The Apache Commons IO library contains utility classes, stream implementations, file filters,
2.8.02.22.0
Core Utils Apache 2.0
commons-lang » commons-lang1 vulnerability
Apache Commons Lang, a package of Java utility classes for the classes that are in java.lang's hierarchy, or are ...
2.63.21.0
FTP Apache 2.0
commons-net » commons-net1 vulnerability
Apache Commons Net library contains a collection of network utilities and protocol implementations.
3.73.13.0
Apache 2.0
io.aeron » aeron-client
Efficient reliable UDP unicast, UDP multicast, and IPC transport protocol.
1.15.31.53.3
Apache 2.0
io.aeron » aeron-driver
Efficient reliable UDP unicast, UDP multicast, and IPC transport protocol.
1.15.31.53.3
Bill of materials Apache 2.0
io.dropwizard.metrics » metrics-bom
Bill of Materials for Metrics
4.1.12.15.0.8
Network Framework Apache 2.0
io.netty » netty-buffer
Netty's byte buffer implementation offering efficient memory management and I/O operations for network applications.
4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec5 vulnerabilities
Netty module for encoding and decoding binary and text-based messages with reusable codec components.
4.1.52.Final4.2.18.Final
DNS Lib Apache 2.0
io.netty » netty-codec-dns2 vulnerabilities 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-haproxy5 vulnerabilities 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-http22 vulnerabilities
Netty codec module for encoding and decoding HTTP messages and handling HTTP protocol logic.
4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-http210 vulnerabilities 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-memcache4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-mqtt1 vulnerability 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-redis6 vulnerabilities 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-smtp1 vulnerability 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-socks4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-stomp2 vulnerabilities 4.1.52.Final4.2.18.Final
Netty Codec Apache 2.0
io.netty » netty-codec-xml2 vulnerabilities 4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-common2 vulnerabilities
Core utilities and abstractions shared across Netty modules, including buffers, threading, and platform detection.
4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-dev-tools4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-handler6 vulnerabilities
A core Netty module that provides high-level channel handlers for protocol implementations and network applications.
4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-handler-proxy1 vulnerability 4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-resolver4.1.52.Final4.2.18.Final
DNS Lib Apache 2.0
io.netty » netty-resolver-dns3 vulnerabilities 4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-transport
Netty module responsible for low-level transport abstraction, used for TCP, UDP, and domain sockets.
4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-transport-rxtx4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-transport-sctp2 vulnerabilities 4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-transport-udt4.1.52.Final4.2.18.Final
Apache 2.0
io.netty » netty-example4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-all
Netty is a NIO client server framework which enables quick and easy development of network applications such as protocol ...
4.1.52.Final4.2.18.Final
DNS Lib Apache 2.0
io.netty » netty-resolver-dns-native-macos4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-transport-native-unix-common
Static library which contains common unix utilities.
4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-transport-native-epoll1 vulnerability
Netty transport implementation using Linux epoll for efficient I/O on native platforms.
4.1.52.Final4.2.18.Final
Network Framework Apache 2.0
io.netty » netty-transport-native-kqueue1 vulnerability 4.1.52.Final4.2.18.Final
Java Spec EDL 1.0
jakarta.xml.bind » jakarta.xml.bind-api
Jakarta XML Binding (JAXB) API that allows Java developers to map Java classes to XML representations and perform ...
2.3.24.0.5
Java Spec EDL 1.0
javax.activation » activation
Jakarta Activation API 2.2 Specification
1.1.12.1.4
Annotation Lib EPL 2.0 +1
javax.annotation » javax.annotation-api(optional)
Jakarta Annotations API
1.3.13.0.0
Dep Injection Apache 2.0
javax.inject » javax.inject(optional)
Jakarta Dependency Injection
12.0.1
Java Spec EPL 2.0 +1
javax.servlet » javax.servlet-api
API for Jakarta Servlet, enabling web applications to handle HTTP requests and responses through a standard interface ...
3.1.06.1.0
Java Spec EPL 2.0 +1
javax.ws.rs » javax.ws.rs-api
Jakarta RESTful Web Services
2.1.14.0.0
Java Spec EPL 2.0 +1
javax.ws.rs » jsr311-api
Java API for RESTful Web Services
1.1.12.1.1
Testing EPL 2.0
junit » junit1 vulnerability
JUnit Jupiter is the API for writing tests using JUnit 5.
4.136.1.3
BSD
net.java.dev.stax-utils » stax-utils
Provides a set of utility classes to integrate StAX into existing XML processing applications.
20070216✔
BSD
net.sf.jung » jung-api
Graph interfaces used by the JUNG project
2.1.1✔
net.sf.jung » jung-algorithms
Algorithms for the JUNG project
2.1.1✔
BSD
net.sf.jung » jung-graph-impl
Graph implementations for the JUNG project
2.1.1✔
Apache 2.0
org.agrona » agrona
High performance primitives and utility library.
0.9.332.6.1
Parser Generator BSD 3-clause
org.antlr » antlr4-runtime
The ANTLR 4 Runtime
4.8-14.13.2
OSGi Apache 2.0
org.apache.aries.blueprint » org.apache.aries.blueprint.core
This bundle contains the core implementation of Blueprint
1.10.21.10.3
Apache 2.0
org.apache.aries.blueprint » blueprint-maven-plugin-annotation(optional)1.3.0✔
Apache 2.0
org.apache.aries.quiesce » org.apache.aries.quiesce.api
Quiesce API.
1.0.0✔
Core Utils Apache 2.0
org.apache.commons » commons-lang31 vulnerability
Apache Commons Lang, a package of Java utility classes for the classes that are in java.lang's hierarchy, or are ...
3.113.21.0
String Utils Apache 2.0
org.apache.commons » commons-text1 vulnerability
The Commons Text library provides additions to the standard JDK text handling. It includes algorithms for string ...
1.91.15.0
Apache 2.0
org.apache.felix » org.apache.felix.metatype
Implementation of the OSGi Metatype Service Specification 1.4
1.2.21.2.4
Apache 2.0
org.apache.karaf.shell » org.apache.karaf.shell.core
This bundle provides OSGi shell integration and console support.
4.2.94.4.12
Apache 2.0
org.apache.karaf.shell » org.apache.karaf.shell.console
This bundle provides compatibility with the previous console.
4.2.94.4.12
Logging Apache 2.0
org.apache.logging.log4j » log4j-api1 vulnerability
API for Apache Log4J, a highly configurable logging tool that focuses on performance and low garbage generation. It has ...
2.13.32.26.1
Logging Apache 2.0
org.apache.logging.log4j » log4j-core7 vulnerabilities
Implementation for Apache Log4J, a highly configurable logging tool that focuses on performance and low garbage ...
2.13.32.26.1
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-1.2-api1 vulnerability
The Apache Log4j 1.x Compatibility API
2.13.32.26.1
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-jcl
The Apache Log4j Commons Logging Adapter
2.13.32.26.1
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-flume-ng
The Apache Log4j Flume Appender
2.13.32.23.1
Apache 2.0
org.apache.logging.log4j » log4j-taglib
The Apache Log4j Tag Library for Web Applications
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-jmx-gui
Swing GUI to remotely edit Log4j configurations. This includes a JConsole plugin and a StatusLogger monitor.
2.13.32.22.0
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-slf4j-impl
The Apache Log4j SLF4J 2.0 API binding to Log4j 2 Core
2.13.32.26.1
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-slf4j18-impl
The Apache Log4j SLF4J 1.8 API binding to Log4j 2 Core
2.13.32.18.0
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-to-slf4j
The Apache Log4j binding between Log4j 2 API and SLF4J.
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-appserver
Provide Log4j as the logging implementation for application servers
2.13.32.26.1
Logging Apache 2.0
org.apache.logging.log4j » log4j-web
The Apache Log4j support for web servlet containers
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-couchdb
CouchDB appender for Log4j.
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-mongodb2
MongoDB appender for Log4j using the MongoDB 2 driver API.
2.13.3✔
Apache 2.0
org.apache.logging.log4j » log4j-mongodb3
MongoDB appender for Log4j using the MongoDB 3 driver API.
2.13.32.23.1
Apache 2.0
org.apache.logging.log4j » log4j-cassandra
Cassandra appender for Log4j.
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-jpa
Apache Log4j Java Persistence API Appender.
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-iostreams
The Apache Log4j streams to log event converters
2.13.32.26.1
Logging Bridge Apache 2.0
org.apache.logging.log4j » log4j-jul
A `java.util.logging` Handler that forwards events to the Log4j API.
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-jpl
The Apache Log4j implementation of java.lang.System.LoggerFinder
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-liquibase
The Apache Log4j Liquibase binding to Log4j 2 Core
2.13.32.19.0
Apache 2.0
org.apache.logging.log4j » log4j-docker
Apache Log4j Docker Support
2.13.32.26.1
Apache 2.0
org.apache.logging.log4j » log4j-kubernetes
Apache Log4j Kubernetes Support
2.13.32.23.1
Apache 2.0
org.apache.logging.log4j » log4j-spring-cloud-config-client
Apache Log4j Spring Cloud Config Client Support
2.13.32.26.1
Concurrency Apache 2.0
org.awaitility » awaitility
A Java DSL for synchronizing asynchronous operations
4.0.34.3.0
Encryption Lib BouncyCastle
org.bouncycastle » bcpkix-jdk15on2 vulnerabilities
The Bouncy Castle Java APIs for CMS, PKCS, EAC, TSP, CMP, CRMF, OCSP, and certificate generation. This jar contains ...
1.661.86
Encryption Lib BouncyCastle
org.bouncycastle » bcprov-jdk15on6 vulnerabilities
The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains the JCA/JCE ...
1.661.86
Encryption Lib BouncyCastle
org.bouncycastle » bcprov-ext-jdk15on3 vulnerabilities
The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider ...
1.661.78.1
org.checkerframework » checker-qual
checker-qual contains annotations (type qualifiers) that a programmerwrites to specify Java code for type-checking by ...
2.11.14.3.0
Apache 2.0
org.codehaus.plexus » plexus-slf4j-logging1.1✔
BSD 2-clause
org.codehaus.woodstox » stax2-api
Stax2 API is an extension to basic Stax 1.0 API that adds significant new functionality, such as full-featured ...
4.2.14.3.1
EPL 2.0
org.eclipse.jdt » org.eclipse.jdt.annotation
JDT Annotations for Enhanced Null Analysis
2.2.4002.4.100
Bill of materials Apache 2.0 +1
org.eclipse.jetty » jetty-bom
Jetty BOM
9.4.28.v2020040812.1.14
Lang Runtime EPL 2.0
org.eclipse.xtend » org.eclipse.xtend.lib
Xtend Artifact for relocation of the old groupId org.eclipse.xtend, relocated to groupId org.eclipse.xtext
2.23.02.44.0
EPL 2.0
org.eclipse.xtend » org.eclipse.xtend.lib.macro
Xtend Artifact for relocation of the old groupId org.eclipse.xtend, relocated to groupId org.eclipse.xtext
2.23.02.44.0
org.eclipse.xtext » org.eclipse.xtext.xbase.lib
The runtime library for Xbase languages.
2.23.02.44.0
Annotation Lib Apache 2.0
org.gaul » modernizer-maven-annotations2.1.03.5.0
org.glassfish.jaxb » jaxb-runtime
JAXB (JSR 222) Reference Implementation
2.3.24.0.9
Apache 2.0 +8
org.glassfish.jersey.bundles » jaxrs-ri
A bundle project producing JAX-RS RI bundles. The primary artifact is an "all-in-one" OSGi-fied JAX-RS RI bundle
2.273.1.12
Apache 2.0 +8
org.glassfish.jersey.connectors » jersey-apache-connector
Jersey Client Transport via Apache
2.273.1.12
Apache 2.0 +8
org.glassfish.jersey.connectors » jersey-grizzly-connector
Jersey Client Transport via Grizzly
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.connectors » jersey-jetty-connector
Jersey Client Transport via Jetty
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.connectors » jersey-jdk-connector
Jersey Client Transport via JDK connector
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.connectors » jersey-netty-connector
Jersey Client Transport via Netty
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-jetty-http
Jetty Http Container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-grizzly2-http
Grizzly 2 Http Container.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-grizzly2-servlet
Grizzly 2 Servlet Container.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-jetty-servlet
Jetty Servlet Container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-jdk-http
JDK Http Container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-netty-http
Netty Http Container.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-servlet
Jersey core Servlet 3.x implementation
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-servlet-core
Jersey core Servlet 3.x implementation
2.273.1.12
Apache 2.0 +8
org.glassfish.jersey.containers » jersey-container-simple-http
Simple Http Container
2.273.1.12
Apache 2.0 +8
org.glassfish.jersey.containers.glassfish » jersey-gf-ejb
Jersey EJB for GlassFish integration
2.274.0.3
Apache 2.0 +4
org.glassfish.jersey.core » jersey-common
Jersey core common packages
2.274.0.3
HTTP Clients Apache 2.0 +8
org.glassfish.jersey.core » jersey-client
Jersey core client implementation
2.274.0.3
Web Framework Apache 2.0 +3
org.glassfish.jersey.core » jersey-server
Jersey core server implementation
2.274.0.3
Validation Apache 2.0 +8
org.glassfish.jersey.ext » jersey-bean-validation
Jersey extension module providing support for Bean Validation (JSR-349) API.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-entity-filtering
Jersey extension module providing support for Entity Data Filtering.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-metainf-services
Jersey extension module enabling automatic registration of JAX-RS providers (MBW/MBR/EM) via META-INF/services ...
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-mvc
Jersey extension module providing support for MVC.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-mvc-bean-validation
Jersey extension module providing support for Bean Validation in MVC.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-mvc-freemarker
Jersey extension module providing support for Freemarker templates.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-mvc-jsp
Jersey extension module providing support for JSP templates.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-mvc-mustache
Jersey extension module providing support for Mustache templates.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-proxy-client
Jersey extension module providing support for (proxy-based) high-level client API.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-servlet-portability
Library that enables writing web applications that run with both Jersey 1.x and Jersey 2.x servlet containers.
2.272.48
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-spring4
Jersey extension module providing support for Spring 5 integration.
2.272.48
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-declarative-linking
Jersey support for declarative hyperlinking.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext » jersey-wadl-doclet
A doclet that generates a resourcedoc xml file: this file contains the javadoc documentation
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-weld2-se
WELD 4.x SE support
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-cdi1x
Jersey CDI 1.1 integration
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-cdi1x-transaction
Jersey CDI 1.x Transactional Support
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-cdi1x-validation
Jersey CDI 1.x Jakarta Validation Support
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-cdi1x-servlet
Jersey CDI 1.x Servlet Support
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.cdi » jersey-cdi1x-ban-custom-hk2-binding
Jersey CDI integration - this module disables custom HK2 bindings
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.rx » jersey-rx-client-guava
Jersey Reactive Client - Guava (ListenableFuture) provider.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.rx » jersey-rx-client-rxjava
Jersey Reactive Client - RxJava (Observable) provider.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.ext.rx » jersey-rx-client-rxjava2
Jersey Reactive Client - RxJava2 (Flowable) provider.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.inject » jersey-hk2
HK2 InjectionManager implementation
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.inject » jersey-cdi2-se
CDI 4 SE InjectionManager implementation
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-jaxb
JAX-RS features based upon JAX-B.
2.274.0.3
JSON Lib Apache 2.0 +2
org.glassfish.jersey.media » jersey-media-json-jackson
Jersey JSON Jackson (2.x) entity providers support module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-json-jackson1
Jersey JSON Jackson (1.x) entity providers support module.
2.272.48
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-json-jettison
Jersey JSON Jettison entity providers support module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-json-processing
Jersey JSON-P (JSR 353) entity providers support proxy module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-json-binding
Jersey JSON-B support module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-kryo
Jersey/JAX-RS Message Body Writer and Reader using Kryo serialization framework
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-moxy
Jersey JSON entity providers support module based on EclipseLink MOXy.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-multipart
Jersey Multipart entity providers support module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.media » jersey-media-sse
Jersey Server Sent Events entity providers support module.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.security » oauth1-client
Module that adds an OAuth 1 support to Jersey client.
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.security » oauth1-server
Module that adds an OAuth 1 support to Jersey server
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.security » oauth1-signature
OAuth1 signature module
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.security » oauth2-client
Module that adds an OAuth 2 support to Jersey client
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework » jersey-test-framework-core
Jersey Test Framework Core
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework » jersey-test-framework-util
Jersey Test Framework Utils
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-bundle
Jersey Test Framework Providers Bundle
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-external
Jersey Test Framework - External container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-grizzly2
Jersey Test Framework - Grizzly2 container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-inmemory
Jersey Test Framework - InMemory container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-jdk-http
Jersey Test Framework - JDK HTTP container
2.274.0.3
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-simple
Jersey Test Framework - Simple HTTP container
2.273.1.12
Apache 2.0 +8
org.glassfish.jersey.test-framework.providers » jersey-test-framework-provider-jetty
Jersey Test Framework - Jetty HTTP container
2.274.0.3
Testing BSD 3-clause
org.hamcrest » hamcrest
Core API and libraries of hamcrest matcher framework.
2.23.0
Testing BSD 3-clause
org.hamcrest » hamcrest-core
Core API and libraries of hamcrest matcher framework.
2.23.0
Testing BSD 3-clause
org.hamcrest » hamcrest-library
Core API and libraries of hamcrest matcher framework.
2.23.0
Annotation Tool Apache 2.0
org.immutables » value
Compile time annotations and compile time annotation processor to generate consistent value object using
2.8.82.12.2
Bytecode Apache 2.0 +2
org.javassist » javassist
Javassist (JAVA programming ASSISTant) makes Java bytecode manipulation
3.27.0-GA3.33.0-GA
Transactions CDDL +2
org.jboss.spec.javax.transaction » jboss-transaction-api_1.1_spec
Jakarta Transactions
1.0.1.Final1.1.1.Final
Apache 2.0
org.jolokia » jolokia-osgi
osgi agent
1.6.21.7.3
MIT
org.kohsuke.metainf-services » metainf-services(optional)
Annotation-driven META-INF/services auto-generation
1.81.11
Mocking MIT
org.mockito » mockito-core
Mockito mock objects library core API and implementation
3.5.115.24.0
Mocking MIT
org.mockito » mockito-inline
Mockito mock objects library core API and implementation
3.5.115.24.0
EPL 1.0
org.opendaylight.controller » repackaged-akka3.0.110.0.15
EPL 1.0
org.opendaylight.controller » sal-common-util3.0.113.0.5
EPL 1.0
org.opendaylight.controller » sal-test-model3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-binding-it3.0.114.0.4
EPL 1.0
org.opendaylight.controller » mdsal-it-base3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-commons
Common clustering utilities
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-commons
Common clustering utilities
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-config
Configuration files for md-sal clustering
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-distributed-datastore3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-distributed-eos3.0.13.0.16
EPL 1.0
org.opendaylight.controller » sal-remoterpc-connector
Gossip-based MD-SAL Action/RPC routing in Pekko clusters
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft
Pekko-based RAFT implementation
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft
Pekko-based RAFT implementation
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-raft-example3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-akka-segmented-journal3.0.111.0.6
EPL 1.0
org.opendaylight.controller » cds-access-api
CDS frontend APIs for backend access
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » cds-access-client
Clustered Data Store client infrastructure
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » cds-access-client
Clustered Data Store client infrastructure
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-cluster-admin-api3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-cluster-admin-impl3.0.114.0.4
EPL 1.0
org.opendaylight.controller » cds-dom-api
DOM APIs exposed by CDS
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » messagebus-api3.0.13.0.16
EPL 1.0
org.opendaylight.controller » messagebus-spi3.0.13.0.16
EPL 1.0
org.opendaylight.controller » messagebus-impl3.0.13.0.16
EPL 1.0
org.opendaylight.controller » messagebus-util3.0.13.0.16
EPL 1.0
org.opendaylight.controller » odl-controller-exp-messagebus
Experimental Message Bus Collector
3.0.13.0.16
EPL 1.0
org.opendaylight.controller » sal-clustering-config
Configuration files for md-sal clustering
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » sal-clustering-config
Configuration files for md-sal clustering
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » features-controller
Controller Production Features
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-controller-akka3.0.111.0.6
EPL 1.0
org.opendaylight.controller » odl-controller-scala3.0.111.0.6
EPL 1.0
org.opendaylight.controller » odl-mdsal-broker
OpenDaylight Controller stack with clustering
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-broker-local
OpenDaylight Controller stack without clustering
3.0.13.0.16
EPL 1.0
org.opendaylight.controller » odl-mdsal-clustering-commons
Common Clustering utilities
3.0.113.0.5
EPL 1.0
org.opendaylight.controller » odl-controller-mdsal-common3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-controller-blueprint
OpenDaylight Controller Blueprint Extension
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-distributed-datastore
Controller Clustered Datastore (akka-based)
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-remoterpc-connector
Clustering remote RPC support
3.0.113.0.5
EPL 1.0
org.opendaylight.controller » odl-mdsal-model-inventory3.0.13.0.16
EPL 1.0
org.opendaylight.controller » odl-controller-model-topology3.0.13.0.16
EPL 1.0
org.opendaylight.controller » odl-toaster
The venerable Toaster
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-jolokia3.0.114.0.4
EPL 1.0
org.opendaylight.controller » features-controller-testing
Controller CSIT Features
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-mdsal-benchmark
Controller benchmarks
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » odl-clustering-test-app3.0.114.0.4
EPL 1.0
org.opendaylight.controller » benchmark-api3.0.114.0.4
EPL 1.0
org.opendaylight.controller » dsbenchmark3.0.114.0.4
EPL 1.0
org.opendaylight.controller » ntfbenchmark3.0.114.0.4
EPL 1.0
org.opendaylight.controller » rpcbenchmark3.0.114.0.4
EPL 1.0
org.opendaylight.controller » features-controller-experimental
Controller Experimental Features
3.0.114.0.4
EPL 1.0
org.opendaylight.controller » netty-event-executor-config
Configuration Wrapper around netty's event executor
0.14.10.19.8
EPL 1.0
org.opendaylight.controller » netty-threadgroup-config
Configuration Wrapper around netty's event group
0.14.10.19.8
EPL 1.0
org.opendaylight.controller » netty-timer-config
Configuration Wrapper around netty's timer
0.14.10.19.8
EPL 1.0
org.opendaylight.controller » threadpool-config-api0.14.10.19.8
EPL 1.0
org.opendaylight.controller » threadpool-config-impl0.14.10.19.8
EPL 1.0
org.opendaylight.controller » odl-controller-exp-netty-config
Common configuration for Netty resources
3.0.18.0.8
EPL 1.0
org.opendaylight.controller.model » model-inventory3.0.13.0.16
EPL 1.0
org.opendaylight.controller.model » model-topology3.0.13.0.16
EPL 1.0
org.opendaylight.controller.samples » sample-toaster3.0.114.0.4
EPL 1.0
org.opendaylight.controller.samples » sample-toaster-consumer3.0.114.0.4
EPL 1.0
org.opendaylight.controller.samples » sample-toaster-provider3.0.114.0.4
EPL 1.0
org.opendaylight.controller.samples » toaster-config
Configuration files for toaster
3.0.1✔
org.opendaylight.controller.samples » features-toaster3.0.1
EPL 1.0
org.opendaylight.controller.samples » clustering-it-config3.0.114.0.4
EPL 1.0
org.opendaylight.controller.samples » clustering-it-model3.0.114.0.4
EPL 1.0
org.opendaylight.controller.samples » clustering-it-provider3.0.114.0.4
EPL 1.0
org.opendaylight.mdsal » features-mdsal
MD-SAL stable feature repository
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » features-mdsal-experimental
MD-SAL experimental feature repository
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-common-api
MD-SAL common APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-common-util7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-api
MD-SAL DOM APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-spi
MD-SAL DOM service provider interfaces
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-broker
MD-SAL core implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-schema-osgi
MD-SAL DOM Schema Service for OSGi
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-inmemory-datastore7.0.116.0.6
EPL 1.0
org.opendaylight.mdsal » mdsal-dom-inmemory-datastore-benchmark7.0.116.0.6
EPL 1.0
org.opendaylight.mdsal » maven-sal-api-gen-plugin7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-api7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-util7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-generator-impl7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-java-api-generator7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » yang-binding
Java binding for YANG
7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-spec-util7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-test-model
mdsal-binding-test-model
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-api
MD-SAL Binding APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-adapter
MD-SAL Binding implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-adapter
MD-SAL Binding implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec-api7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec-spi7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-dom-codec-osgi7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-runtime-api7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-runtime-spi7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-runtime-osgi7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-spi
MD-SAL Binding API helper classes
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-util
MD-SAL Binding utility APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-binding-test-utils7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-common-api
Entity Ownership Service common APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-common-spi7.0.112.0.8
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-dom-api
Entity Ownership Service DOM APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-dom-simple
Entity Ownership Service (single-node)
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-binding-api
Entity Ownership Service Binding APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-eos-binding-adapter
Entity Ownership Service Binding implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-singleton-common-api7.0.112.0.8
EPL 1.0
org.opendaylight.mdsal » mdsal-singleton-dom-impl7.0.112.0.8
EPL 1.0
org.opendaylight.mdsal » mdsal-trace-api7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-trace-cli7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-trace-impl7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding
MD-SAL full Java Binding functionality
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-base
MD-SAL Java Binding base support
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-runtime-api
MD-SAL Java Binding runtime APIs
7.0.113.0.10
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-runtime
MD-SAL Java Binding runtime
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-api
MD-SAL Java Binding APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-binding-dom-adapter
MD-SAL Java Binding/DOM adapter
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom
MD-SAL full DOM functionality
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom-api
MD-SAL DOM APIs
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom-broker
MD-SAL DOM implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-dom-runtime
MD-SAL DOM runtime
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-common
MD-SAL common APIs and utilities
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-common
Entity Ownership Service common API
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-dom
Entity Ownership Service DOM API
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-eos-binding
Entity Ownership Service Binding support
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-singleton-common
MD-SAL Cluster Singleton Service commons
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-singleton-dom
MD-SAL Cluster Singleton Service implementation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-trace
MD-SAL Trace tooling
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-yanglib-api
YANG library API
0.12.10.22.2
EPL 1.0
org.opendaylight.mdsal » mdsal-yanglib-rfc78950.12.10.13.16
EPL 1.0
org.opendaylight.mdsal » mdsal-yanglib-rfc8525
RFC8525 YANG library implementation
0.12.10.22.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-exp-yanglib-api
MD-SAL YANG (Module) Library APIs
0.12.10.22.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-exp-yanglib-rfc7895
MD-SAL YANG Module Library (RFC7895)
0.12.10.13.16
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-exp-yanglib-rfc8525
MD-SAL YANG Library (RFC8525)
0.12.10.22.2
EPL 1.0
org.opendaylight.mdsal » mdsal-rfc8294-netty
RFC8294 Netty utilities
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal » mdsal-replicate-common7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » mdsal-replicate-netty7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-exp-replicate-common7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-exp-replicate-netty7.0.17.0.14
EPL 1.0
org.opendaylight.mdsal » odl-mdsal-rfc8294-netty
Netty support for RFC8294
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal » mdsal-docs
MD-SAL documentation
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » iana-if-type
iana-if-type@2023-01-26.yang
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » rfc7224-20180703-iana-if-type
iana-if-type@2018-07-03.yang
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » iana-routing-types
iana-routing-types@2021-10-19
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.iana » iana-hardware
iana-hardware@2018-03-13
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc6991
RFC6991 Common YANG Data Types
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc6991-ietf-inet-types
rfc6991-ietf-inet-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc6991-ietf-yang-types
rfc6991-ietf-yang-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc7223
rfc7223
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc7277
rfc7277
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc7895
YANG Module Library (pre-NMDA) model
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc7952
RFC7952 YANG Metadata
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8294
RFC8294 Common YANG Data Types for the Routing Area
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8294-ietf-routing-types
RFC8294 ietf-routing-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342
RFC8342 Network Management Datastore Architecture
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342-ietf-datastores
RFC8342 ietf-datastores
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8342-ietf-origin
RFC8342 ietf-origin
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8343
RFC8343 Interface Management
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8344
RFC8343 IP Management
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345
RFC8345 Network Topologies
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network
RFC8345 ietf-network
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-state
RFC8345 ietf-network for non-NMDA
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-topology
RFC8345 ietf-network-topology
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8345-ietf-network-topology-state
RFC8345 ietf-network-topology for non-NMDA
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8346
RFC8346 Layer 3 Topologies
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8346-ietf-l3-unicast-topology
RFC8346 ietf-l3-unicast-topology
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8346-ietf-l3-unicast-topology-state
RFC8346 ietf-l3-unicast-topology-state
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348
RFC8348 Hardware Management
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348-ietf-hardware
RFC8348 ietf-hardware
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8348-ietf-hardware-state
RFC8348 ietf-hardware-state
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349
RFC8349 Routing Management
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-routing
RFC8349 ietf-routing
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-ipv4-unicast-routing
RFC8349 ietf-ipv4-unicast-routing
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8349-ietf-ipv6-unicast-routing
RFC8349 ietf-ipv6-unicast-routing
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8519
RFC8519 Network Access Control Lists
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8519-ietf-access-control-list
RFC8519 ietf-access-control-list
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8519-ietf-ethertypes
RFC8519 ietf-ethertypes
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8519-ietf-packet-fields
RFC8519 ietf-packet-fields
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8520
RFC8520 Manufacturer Usage Description
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8520-ietf-acldns
RFC8520 ietf-acldns
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8520-ietf-mud
RFC8520 ietf-mud
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8525
YANG Library (NMDA) model
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8528
RFC8528 YANG Schema Mount
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8529
RFC8529 Network Instances
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8530
RFC8530 Logical Network Elements
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8542
RFC8542 Fabric Topology in Data-Center Networks
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8542-ietf-dc-fabric-topology
RFC8542 ietf-dc-fabric-topology
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8542-ietf-dc-fabric-types
RFC8542 ietf-dc-fabric-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8776
RFC8776 Common YANG Data Types for Traffic Engineering
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8776-ietf-te-types
RFC8776 ietf-te-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8776-ietf-te-packet-types
RFC8776 ietf-te-packet-types
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8795
RFC8795 YANG Data Model for Traffic Engineering (TE) Topologies
7.0.111.0.16
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8795-ietf-te-topology
RFC8795 ietf-te-topology
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.binding.model.ietf » rfc8795-ietf-te-topology-state
RFC8795 ietf-te-topology-state
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » yang-ext
yang-ext
2013.09.07.19.12013.09.07.29.2
EPL 1.0
org.opendaylight.mdsal.model » general-entity
general-entity
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal.model » opendaylight-l2-types2013.08.27.19.12013.08.27.29.2
EPL 1.0
org.opendaylight.mdsal.model » ietf-type-util7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » ietf-topology
ietf-topology
2013.10.21.19.12013.10.21.29.2
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc6991
Models from RFC6991
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7223
Models from RFC7223
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7224
Models from RFC7224
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7277
Models from RFC7277
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7895
Models from RFC7895
7.0.18.0.16
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc7952
Models from RFC7952
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8294
Models from RFC8294
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8342
Models from RFC8342
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8343
Models from RFC8343
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8344
Models from RFC8344
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8345
NMDA models from RFC8345
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8345-non-nmda
Non-NMDSA models from RFC8345
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8346
NMDA models from RFC8346
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8346-non-nmda
Non-NMDA models from RFC8346
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8348
NMDA models from RFC8348
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8348-non-nmda
Non-NMDA models from RFC8348
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8349
Models from RFC8349
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8519
Models from RFC8519
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8520
Models from RFC8520
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8525
Models from RFC8525
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8528
Models from RFC8528
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8529
Models from RFC8529
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8530
Models from RFC8530
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8542
Models from RFC8542
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8776
Models from RFC8776
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8795
Models from RFC8795
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-rfc8795-non-nmda
Non-NMDA models from RFC8795
7.0.114.0.22
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-draft-clemm-netmod-yang-network-topo-01-minimal
Models from draft-clemm-netmod-yang-network-topo-01 (minimal)
7.0.117.0.2
EPL 1.0
org.opendaylight.mdsal.model » odl-mdsal-model-odl-l2-types
OpenDaylight-specific model of Layer 2 types
7.0.117.0.2
EPL 1.0
org.opendaylight.odlparent » karaf.branding8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » opendaylight-karaf-resources
Resources for opendaylight-karaf
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » opendaylight-karaf-empty8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » bundles-test-lib8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » logging-markers
OpenDaylight-specific SLF4J Markers
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » bcpkix-framework-ext8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » bcprov-framework-ext8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » features-odlparent
OpenDaylight third-party features
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-antlr4
ANTLR v4
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-apache-commons-codec
Apache commons-codec
8.0.010.0.6
EPL 1.0
org.opendaylight.odlparent » odl-apache-commons-lang3
Apache commons-lang3
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-apache-commons-net
Apache commons-net
8.0.010.0.6
EPL 1.0
org.opendaylight.odlparent » odl-apache-commons-text
Apache commons-text
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-dropwizard-metrics
Dropwizard Metrics 4.x
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-gson
Gson
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-guava8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-jackson-2.10
Jackson 2.10
8.0.08.0.3
EPL 1.0
org.opendaylight.odlparent » odl-javassist-3
Javassist
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-jersey-2
Jersey 2.x
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-jung-2.1
JUNG: Java Universal Network/Graph Framework
8.0.010.0.6
EPL 1.0
org.opendaylight.odlparent » odl-lmax-3
LMAX Disruptor 3.x
8.0.013.1.7
EPL 1.0
org.opendaylight.odlparent » odl-netty-4
Netty 4.x
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-karaf-feat-feature8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-karaf-feat-jdbc8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-karaf-feat-jetty8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-karaf-feat-war8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-servlet-api
Java servlet API 3.1.x
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-stax2-api
StAX2 API
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-woodstox
Woodstox StAX
8.0.015.0.2
EPL 1.0
org.opendaylight.odlparent » odl-ws-rs-api
Java API for RESTful Web Services
8.0.015.0.2
EPL 1.0
org.opendaylight.yangtools » yang-data-util
Utilities for working with YANG-modeled data in normalized form.
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » concepts
Common concepts
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-common
Common YANG definitions
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-api
Object model for normalized YANG-modeled data
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-xpath-api
yang-data-xpath-api
0.4.00.4.12
EPL 1.0
org.opendaylight.yangtools » yang-data-impl
yang-data-impl
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-transform
yang-data-transform
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-jaxen
yang-data-jaxen
6.0.06.0.12
EPL 1.0
org.opendaylight.yangtools » yang-data-codec-binfmt
DataInput/Output for NormalizedNodes
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-codec-gson
JSON (RFC7951) encoding for NormalizedNodes
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-data-codec-xml
XML (RFC7950) encoding for NormalizedNodes
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-model-api
YANG language object model and related interfaces
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-model-export
yang-model-export
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-model-util
yang-model-util
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-parser-api
YANG parser API
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-parser-spi
YANG parser SPI
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-parser-reactor
YANG parser reactor
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-parser-impl
YANG parser
6.0.014.0.25
EPL 1.0
org.opendaylight.yangtools » yang-parser-antlr
RFC6020/RFC7950 ANTLR grammars
6.0.07.0.18
EPL 1.0
org.opendaylight.yangtools » yang-parser-rfc7950
RFC6020/RFC7950 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-test-util
yang-test-util
6.0.016.1.0
Maven Plugins EPL 1.0
org.opendaylight.yangtools » yang-maven-plugin
This plugin is a wrapper for "yang to source code" generation.
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-maven-plugin-spi
yang-maven-plugin-spi
6.0.09.0.10
EPL 1.0
org.opendaylight.yangtools » odlext-model-api
OpenDaylight yang-ext metamodel
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odlext-parser-support
OpenDaylight yang-ext parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » openconfig-model-api
OpenConfig extensions metamodel
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » openconfig-parser-support
OpenConfig extensions parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6241-model-api
RFC6241 extensions for unbound metadata
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6241-parser-support
RFC6241 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6536-model-api
RFC6536 metamodel
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6536-parser-support
RFC6536 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6643-model-api
RFC6643 extensions for SMIv2
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc6643-parser-support
RFC6643 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc7952-data-api
RFC7952 data model extensions
6.0.010.0.13
EPL 1.0
org.opendaylight.yangtools » rfc7952-data-util
RFC7952 data model utilities
6.0.010.0.13
EPL 1.0
org.opendaylight.yangtools » rfc7952-model-api
RFC7952 metamodel
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc7952-parser-support
RFC7952 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc8040-model-api
RFC8040 model API
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc8040-parser-support
RFC8040 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc8528-data-api
RFC8528 data model extensions
6.0.010.0.13
EPL 1.0
org.opendaylight.yangtools » rfc8528-data-util
RFC8528 data model utilities
6.0.010.0.13
EPL 1.0
org.opendaylight.yangtools » rfc8528-model-api
RFC8528 model API
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » rfc8528-parser-support
RFC8528 parser support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-xpath-api
YANG XPath yang-xpath-api
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-xpath-antlr
YANG XPath ANTLR grammars
6.0.07.0.18
EPL 1.0
org.opendaylight.yangtools » yang-xpath-impl
YANG XPath parser
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » util
Common utilities
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » yang-common-netty
Netty utilities for Common YANG definitions
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » mockito-configuration
Default mockito configuration
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » testutils
Random test utilities
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » features-yangtools
YANG Tools Stable Features
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » features-yangtools-experimental
YANG Tools Experimental Features
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-util
YANG Tools common utilities
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-common
Common YANG-related definitions
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-parser-api
YANG metamodel and parser APIs
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-parser
YANG parser reference implementation
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-data-api
YANG modeled data APIs
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-data
YANG modeled data implementation
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-codec
Serialization/deserialization support for various formats
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-export
YANG model export
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-netty
YANG Tools/netty-buffer utilities
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-xpath-api
YANG XPath API
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-xpath
YANG XPath support
6.0.016.1.0
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-exp-data-xpath-api
YANG-modeled data XPath APIs
0.4.00.4.12
EPL 1.0
org.opendaylight.yangtools » odl-yangtools-exp-data-xpath
XPath support for YANG-modeled data
0.4.00.4.12
EPL 1.0
org.opendaylight.yangtools » yangtools-docs
YANG Tools documentation
6.0.016.1.0
Apache 2.0
org.ops4j.pax.exam » pax-exam4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-container-forked4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-container-karaf4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-container-native
Leverages the OSGi R4.2 Launch API so it just works with newer osgi implementations.
4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-extender-service4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-inject4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-invoker-junit4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-features4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-junit44.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-link-mvn4.13.34.14.0
Apache 2.0
org.ops4j.pax.exam » pax-exam-link-assembly
Link Files to its own content.
4.13.34.14.0
Apache 2.0
org.ops4j.pax.url » pax-url-link
OPS4J Pax Url - link: protocol handler
2.5.43.0.3
Apache 2.0
org.ops4j.pax.url » pax-url-aether
OPS4J Pax Url - mvn: protocol handler
2.5.43.0.3
Apache 2.0
org.ops4j.pax.url » pax-url-wrap
OPS4J Pax Url - wrap: protocol handler
2.5.43.0.3
Apache 2.0
org.ops4j.pax.web » pax-web-api7.2.1611.1.3
OSGi Apache 2.0
org.osgi » osgi.cmpn
OSGi Compendium Release 7, Interfaces and Classes for use in compiling bundles
6.0.07.0.0
OSGi Apache 2.0
org.osgi » org.osgi.core
OSGi Core Release 8, Interfaces and Classes for use in compiling bundles
6.0.08.0.0
OSGi Apache 2.0
org.osgi » org.osgi.service.event
OSGi Companion Code for org.osgi.service.event Version 1.4.1
1.3.11.4.1
Mocking Apache 2.0
org.powermock » powermock-api-mockito2
PowerMock API for Mockito 2.+..
2.0.72.0.9
Apache 2.0
org.powermock » powermock-api-support
PowerMock API Utility classes.
2.0.72.0.9
Mocking Apache 2.0
org.powermock » powermock-core
Various utilities for accessing internals of a class.
2.0.72.0.9
Mocking Apache 2.0
org.powermock » powermock-module-junit4
PowerMock support module for JUnit 4.x.
2.0.72.0.9
Apache 2.0
org.powermock » powermock-reflect
Various utilities for accessing internals of a class.
2.0.72.0.9
MIT
org.reactivestreams » reactive-streams
A Protocol for Asynchronous Non-Blocking Data Sequence
1.0.31.0.4
JVM Languages Apache 2.0
org.scala-lang » scala-library1 vulnerability
Standard library for the Scala Programming Language Version 3
2.13.33.10.0
Scala Compiler Apache 2.0
org.scala-lang » scala-reflect
Reflection Library for the Scala Programming Language
2.13.32.13.18
Apache 2.0
org.scala-lang.modules » scala-java8-compat_2.13
scala-java8-compat
0.9.11.0.2
Parser Generator Apache 2.0
org.scala-lang.modules » scala-parser-combinators_2.13
scala-parser-combinators
1.1.22.5.0
Testing Apache 2.0
org.skyscreamer » jsonassert
Library for writing tests that checks JSON documents (useful for testing responses from REST services).
1.5.01.5.3
Logging Bridge Apache 2.0
org.slf4j » jcl-over-slf4j
Jakarta/Apache commons logging 1.2 implemented over SLF4J
1.7.282.0.20
Logging MIT
org.slf4j » slf4j-api
API for SLF4J (The Simple Logging Facade for Java) which serves as a simple facade or abstraction for various logging ...
1.7.282.0.20
org.slf4j » slf4j-log4j12
SLF4J Reload4j Provider
1.7.282.0.20
Logging Bridge Apache 2.0
org.slf4j » log4j-over-slf4j
Log4j implemented over SLF4J
1.7.282.0.20
Logging MIT
org.slf4j » slf4j-simple
Binding/provider for SLF4J, which outputs all events to System.err. Only messages of level INFO and higher are printed.
1.7.282.0.20
Apache 2.0
org.sonatype.plexus » plexus-build-api
An API that lets Maven plugins report file changes, messages and progress to whatever is
0.0.71.3.0
Mocking Apache 2.0
org.springframework.osgi » spring-osgi-mock
Mocks for OSGi interfaces.
1.2.1✔
BSD 3-clause
org.threeten » threeten-extra
Additional functionality that enhances JSR-310 dates and times in Java SE 8 and later
1.5.01.10.0
Testing Apache 2.0
org.xmlunit » xmlunit-core1 vulnerability
XMLUnit for Java
2.7.02.14.0
Apache 2.0
org.xmlunit » xmlunit-assertj
XMLUnit with AssertJ fluent API
2.7.02.14.0
Testing Apache 2.0
org.xmlunit » xmlunit-matchers
XMLUnit for Java Hamcrest Matchers
2.7.02.14.0
Testing BSD 3-clause
org.xmlunit » xmlunit-legacy
XMLUnit 1.x Compatibility Layer
2.7.02.14.0
Bill of materials Apache 2.0
tech.pantheon.triemap » bom
Bill of Materials POM for the TrieMap project
1.2.01.4.0
XML Processing Apache +1
xml-apis » xml-apis
Collection of standard XML processing interfaces including DOM, SAX, and JAXP, providing foundational APIs for XML ...
1.4.012.0.2